Chapter 13
The Basics of Spreadsheets
Arranging Information

• Frequently, textual information is organized into lists:
  – shopping lists
  – invitation lists
  – “to do” lists
  – class lists

• Computers don’t have your knowledge about how big the list is

• Separate lines help the computer get it
An Array of Cells

- Spreadsheets give us an **array** of cells for setting up a list.
- The **lines** are part of the GUI.
- They help the computer and us agree on:
  - What an item is
  - How the positions of items are related to each other

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Short-tailed shearwater</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>Swainson's hawk</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>Wheatear</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>Arctic tern</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>Willow warbler</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>Long-tailed skua</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
An Array of Cells

• Four of the six items do not fit within the lines provided
• Entries do not straddle cells
• Each item occupies only the cell in which it is typed
• Items only spill when the cells to their right are unused
• We can either let the entries be clipped or make the cells wider
Sorting the Data

• A common operation on any list is to alphabetize or sort it

• We must specify which items to sort

• Select the list by dragging the cursor across the cells

• Resulting selection is indicated with highlighting
Sorting the Data

- All of the items are selected (including the white item)
- The item is a different color only because it was the first cell selected
- The Sort operation is either among the menu items or is an icon
- Sorting can be either ascending or descending
Sorting the Data

• The sorting software orders the list alphabetically on the first letter of the entry
• The spreadsheet views that the cell entries are “atomic” or “monolithic”
Adding More Data to the List

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Arctic tern</td>
<td>Sterna</td>
<td>paradisaea</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Long-tailed skua</td>
<td>Stercorarius</td>
<td>longicaudus</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Short-tailed shearwater</td>
<td>Puffinus</td>
<td>tenuirostris</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Swainson's hawk</td>
<td>Buteo</td>
<td>swainsoni</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Wheatear</td>
<td>Oenanthe</td>
<td>oenanthe</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Willow warbler</td>
<td>Phylloscopus</td>
<td>trochilus</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Adding More Data to the List

• Spreadsheets give us the ability to format cell entries with the kinds of formatting found in word processors:
  – *italics*, **bold**, font styles, font sizes, justification, *colored* text and so on
• Formatting facilities are frequently found under the *Format* menu
## Formatting Entries

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Arctic tern</td>
<td><em>Sternula paradisaea</em></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Long-tailed skua</td>
<td><em>Stercorarius longicaudus</em></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Short-tailed shearwater</td>
<td><em>Puffinus tenuirostris</em></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Swainson's hawk</td>
<td><em>Buteo swainsoni</em></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Wheatear</td>
<td><em>Oenanthe oenanthe</em></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Willow warbler</td>
<td><em>Phylloscopus trochilus</em></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Naming Rows and Columns

• If the whole list is highlighted, how do we specify which column should be sorted?

• Spreadsheet programs automatically provide a naming scheme for referring to specific cells

• Columns are labeled with letters and the rows are labeled with numbers
Naming Rows and Columns

• This allows us to refer to a:
  – whole column by its letter
  – entire row by its number
Naming Rows and Columns

• The naming scheme allows a group of cells to be referenced:
  – Naming the first cell and the last cell and placing a colon (:) 
  – Example: B2:D7 is called a cell range
Headings

• It is convenient to name the rows and columns with more meaningful names by giving them *headings*
Spreadsheet Summary

- Spreadsheets are formed from cells that are displayed as rectangles in a grid
- Information entered in a cell is treated as an elemental piece of data
- A list of items that can be sorted
- Spreadsheets provide a labeling for specifying the column/row
Common Spreadsheet Operations

Table 13.1  Common spreadsheet operations in recent versions of spreadsheet software; for Excel 2010 and 2013 check the tab shown in brackets.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Change column width manually</td>
<td>Place cursor at right side of column name, then drag</td>
<td>Place cursor at right side of column name, then drag</td>
</tr>
<tr>
<td>Change column width automatically</td>
<td>Format &gt; Column &gt; Autofit Selection [Home]</td>
<td>Format &gt; Column &gt; Optimal Width . . .</td>
</tr>
<tr>
<td>Clear cells</td>
<td>Edit &gt; Clear &gt; All [Home]</td>
<td>Edit &gt; Delete Contents . . .</td>
</tr>
<tr>
<td>Delete columns, rows</td>
<td>Edit &gt; Delete . . . [Home]</td>
<td>Edit &gt; Delete Cells . . .</td>
</tr>
<tr>
<td>Hide a column</td>
<td>Format &gt; Column &gt; Hide [View]</td>
<td>Format &gt; Column &gt; Hide</td>
</tr>
</tbody>
</table>

*Note: All spreadsheet applications provide these common operations; explore your system.*
Computing with Spreadsheets

- Spreadsheets don’t have to contain a single number to be useful
- Their most common application is to process numerical data
- Numerical data is usually associated with textual information so most spreadsheets allow both
Writing a Formula

• First, decide what you want to calculate
• Are the values in a particular cell (such as F2)
• Within a cell:
  – Begin a formula with a = (equals sign)
  – Type a cell address (or click it)
  – Enter the math operand and any numbers that may be involved

= F2 * 0.621
Writing a Formula

<table>
<thead>
<tr>
<th>Common Name</th>
<th>Distance (Km)</th>
<th>Length (m)</th>
<th>Distance (Mi)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Swainson's hawk</td>
<td>13500</td>
<td>0.52</td>
<td>=F2*0.621</td>
</tr>
<tr>
<td>Wheatear</td>
<td>13500</td>
<td>0.16</td>
<td></td>
</tr>
<tr>
<td>Willow warbler</td>
<td>15500</td>
<td>0.11</td>
<td></td>
</tr>
<tr>
<td>Short-tailed shearwater</td>
<td>12500</td>
<td>0.43</td>
<td></td>
</tr>
<tr>
<td>Long-tailed skua</td>
<td>16000</td>
<td>0.51</td>
<td></td>
</tr>
<tr>
<td>Arctic tern</td>
<td>19000</td>
<td>0.35</td>
<td></td>
</tr>
</tbody>
</table>
Writing a Formula

• Using a cell address (F2) in a formula means that if the value in F2 ever changes, then the value (in H2) automatically changes.

• H2 holds a formula, not text or a number.

• H2 is actually: H2 = F2 * 0.641
Repeating a Formula

• Similar computations can be done for other cells in that column:
  – Enter them in the same way as you entered the first formula
  – Copy/Paste
    • Don’t worry, it does NOT copy the formula exactly!
  – Filling “pulls” the formula into other cells
Copy/Paste

• When a cell is selected in Excel, it is indicated by an animated highlight (the dashes revolve around the box)
  – Other spreadsheet software may simply show a solid box around the item.

• The cell’s contents are shown in the Edit Formula window

• Copy this cell, select the remaining cells in the column by dragging the mouse across them, and Paste (\(^V\))
Copy/Paste

• Check the result in the cell.
  – The original cell had the formula: $F2 \times 0.621$
  – The new cell has the formula: $F3 \times 0.621$
  – Which is just what we want

• The formula was transformed into $F3 \times 0.621$ when it was pasted
Filling

• Filling is another way to copy information, including formulas, to another cell
• Notice the small box or tab in the cell’s lower-right corner
• This is the fill handle
Filling

- When the handle is grabbed, it becomes a +
- Pull the handle down the column (or across a row)
- This process is known as *filling*
- It automates copying and pasting
Transforming Formulas: Relative Versus Absolute

• The spreadsheet software automatically transforms the formulas as it pastes/fills them into a cell

• The cell contains a relative cell reference (F2)

• Spreadsheets allow two kinds of cell references—relative and absolute

• The absolute cell reference to this cell is $F$2
Relative Versus Absolute

- **Relative** means "relative position from a cell"
- In the formula H2 =F2*0.621 into H2, the software noticed that cell F2 is two cells to the left of H2
- The formula refers to a cell in the same row, but two cells to the left
- This is a relative reference
Relative Versus Absolute

<table>
<thead>
<tr>
<th>Common Name</th>
<th>Distance(Km)</th>
<th>Length(m)</th>
<th>Distance(Mi)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Swainson's hawk</td>
<td>13500</td>
<td>0.52</td>
<td>(=F2*0.621)</td>
</tr>
<tr>
<td>Wheatare</td>
<td>13500</td>
<td>0.16</td>
<td></td>
</tr>
<tr>
<td>Willow warbler</td>
<td>15500</td>
<td>0.11</td>
<td></td>
</tr>
<tr>
<td>Short-tailed shearwater</td>
<td>12500</td>
<td>0.43</td>
<td></td>
</tr>
<tr>
<td>Long-tailed skua</td>
<td>16000</td>
<td>0.51</td>
<td></td>
</tr>
<tr>
<td>Arctic tern</td>
<td>19000</td>
<td>0.35</td>
<td>(=F7*0.621)</td>
</tr>
</tbody>
</table>
Relative Versus Absolute

• Absolute references *always* refer to a fixed position—the software never adjusts it.

• There are two ways a formula can be relative, making four cases:
  – F2—column and row are both relative
  – $F2$—absolute column, but relative row
  – F$2$—relative column, but absolute row
  – $F$2—column and row are both absolute
Cell Formats

- Flying score is the distance divided by the length.
- The scores are somewhat difficult to read because they have too many digits.
- All spreadsheet software provides control over formatting.
Excel’s Formatting GUI
Cell Formats

• This GUI gives us control over:
  – The types of information in the fields (Category)
  – The number of decimal digits for the Number category chosen
  – Setting the “1000s” separators (commas for North America)
  – The display of negative numbers
Functions

• Spreadsheet software provides functions for computing common summary operations
  – totals (sum), averages, maximums (max), and others

• To use these functions, give the function name and specify the cell range to be summarized in parentheses after it:
  \( =\text{max}(J2:J7) \)
Functions

• There is a full list of function names under **Insert > Insert Function**. 

• A computation value inherits the formatting of the cell.

• When the function is then dragged across to other columns, it brings its formatting with it.
Functions

We compute column maxima and averages

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Common Name</td>
<td>Distance(Km)</td>
<td>Length(m)</td>
<td>Distance(MI)</td>
<td>Flying Score</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Swainson's hawk</td>
<td>13500</td>
<td>0.52</td>
<td>8383.5</td>
<td>25962</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Wheatear</td>
<td>13500</td>
<td>0.16</td>
<td>8383.5</td>
<td>84375</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Willow warbler</td>
<td>15500</td>
<td>0.11</td>
<td>9625.5</td>
<td>140909</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Short-tailed shearwater</td>
<td>12500</td>
<td>0.43</td>
<td>7762.5</td>
<td>29070</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Long-tailed skua</td>
<td>16000</td>
<td>0.51</td>
<td>9936</td>
<td>31373</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Arctic tern</td>
<td>19000</td>
<td>0.35</td>
<td>11799</td>
<td>54286</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Maximum:</td>
<td>19000</td>
<td>0.52</td>
<td>11799</td>
<td>140909</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Average:</td>
<td>15000</td>
<td>0.35</td>
<td>9315</td>
<td>60995.61</td>
<td></td>
</tr>
</tbody>
</table>
Displaying Hidden Columns

- Notice the hidden columns between B and F
- When we “unhide” these columns, we have the final spreadsheet

<table>
<thead>
<tr>
<th>B</th>
<th>C</th>
<th>D</th>
<th>Migration</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Common Name</td>
<td>Genus Species</td>
<td>Migration</td>
<td>Distance(Km)</td>
<td>Distance(Mi)</td>
<td>Flying Score</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Swainson's hawk</td>
<td>Buteo swainsoni</td>
<td>USA-Argentina</td>
<td>13500</td>
<td>8383.5</td>
<td>25962</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Wheatear</td>
<td>Oenanthe oenanthe</td>
<td>Alaska-E Africa</td>
<td>13500</td>
<td>8383.5</td>
<td>84375</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Willow warbler</td>
<td>Phylloscopus trochilus</td>
<td>Chukotka-S Africa</td>
<td>15500</td>
<td>9625.5</td>
<td>140909</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Short-tailed shearwater</td>
<td>Puffinus tenuirostris</td>
<td>Tasmania-Bering Strait</td>
<td>12500</td>
<td>7762.5</td>
<td>29070</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Long-tailed skua</td>
<td>Stercorarius longicaudus</td>
<td>N Greenland-Southern Ocean</td>
<td>16000</td>
<td>9936</td>
<td>31373</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Arctic tern</td>
<td>Sterna paradisaea</td>
<td>Greenland-Antarctic</td>
<td>19000</td>
<td>11799</td>
<td>54286</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Maximum</td>
<td></td>
<td></td>
<td>19000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Average</td>
<td></td>
<td></td>
<td>15000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Figure 13.2** Final spreadsheet for the migratory birds.
Charts

- Spreadsheets organize our data and compute new values.
- It is helpful to see the results graphically when comparing values.
- Spreadsheet software makes creating charts easy.
- Select the values to be plotted and then click **Chart**.
Charts

• Spreadsheets are good at displaying data graphically
• Select the values to be plotted
• Choose Insert, then Chart, and select the type of chart
• The software will detect the heading
Charts

Figure 13.3 The Flying Score graph after selecting an XY-Scatter Plot chart with “points.”
Daily Spreadsheets

• Spreadsheets are convenient, versatile tools that simplify computing
• Here are some ways to use spreadsheets to organize:
  – Track our performance in our exercise program
  – Set up an expense budget
  – Keep a list of books and DVDs we’ve lent
  – Follow our favorite team’s successes
  – Save records generated while online banking
  – Address books
Solving a Problem of Personal Interest

• Scenario:
  – Time Zone Cheat Sheet
  – People you want to chat with live in different time zone
  – It’s not always convenient to chat when you want to call because they may be sleeping, working, or studying
Series Fill

- There is certain data that are “special:” days, dates, and time
- When the software *fills* these values, it *automatically increments* them
  - Adding 1 to Sunday results in Monday
  - Adding 1 to January 31 results in February 1
  - Adding 1 to 12:00 am produces 1:00 pm
- However, if you type Sunday and want Sunday, use Copy/Paste
Series Fill

• The best way to use *series fill* is to:
  – Enter the first two items of the series into adjacent cells
  – Select the two cells
  – Pull on the handle to fill either the row or column

• The double-cell fill indicates a series where increment between successive items is the difference between them
### Figure 13.5
The time zone cheat sheet (assuming “me” lives in LA) for five buddies; “sunset gold” indicates yesterday, “sunrise magenta” indicates tomorrow.
Getting Started…

• Begin by placing the headings at the top
• Under your name enter midnight
• Fill down the column to the end of the day
• Next, add the times in for your friends
• Grab the fill handle and fill the column up and down
  – The software assumes that rows above are earlier and rows below are later
Figure 13.6  Adding the time zone for a buddy (a) prior to filling, and (b) after filling "up."
Finishing Up the Time Zones

- Add colors to the cells that refer to “yesterday” and “tomorrow” to remind you of day changes
- Any cells that start a column and contain “PM” refer to yesterday
- Any cells that end a column and contain “AM” times refer to tomorrow
Pizza Discount Table

• Scenario:
  – Save money on pizza based on how much you bought the previous month
    • no discount for none or one
    • 5% discount for 2 or 3
    • 10% discount for 4 or 5
    • 15% discount for 6 or 7
    • 20% discount for 8 or more
  – 10” costs $7.85, 12” costs $11.30, 14” costs $15.39
A Plan

- Pool your purchases with your friends, designate one person as the pizza buyer – everyone’s purchases will count towards the discount.
The Requirements

- =D3*D4 is not a good choice because it uses relative references
  - only does work for that one cell
  - we want it to work for the whole table
Absolute References

• we want
  \[ D4 = D3 \times C4 \]
  \[ E6 = E3 \times C6 \]

• to make them absolute we will use the $ symbol
  – \[ D4 = D\$3 \times \$C4 \]
  – allows the first term $D3 to always refer to the third row, and $C4 to always refer to the C column
Solving a Problem of Personal Interest

• Scenario:
  – Paying Off a Loan
  – Your uncle has agreed to lend you some money, but he’s charging 5% interest
  – To decide how much to borrow, create a spreadsheet of monthly payments required for different amounts borrowed for different times
Paying Off a Loan Initial Setup

<table>
<thead>
<tr>
<th></th>
<th>Payments</th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td></td>
<td>6</td>
<td>12</td>
<td>18</td>
<td>24</td>
</tr>
<tr>
<td>3</td>
<td>$1,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>$1,500</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>$2,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>$2,500</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>$3,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>$3,500</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>$4,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>$4,500</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>$5,000</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Paying Off a Loan

• Among the functions available with spreadsheets is the “payment” (PMT) computation.

• The GUI is displayed for PMT:

• The inputs to the function are:
  – The monthly interest **Rate**, which is 1/12th of the annual rate
  – The number of payments (**Nper**) is the amount in row 2 for this column
  – The present value, or the amount of the loan (**Pv**)
PMT GUI

Calculates the payment for a loan based on constant payments and a constant interest rate.

Rate is the interest rate per period for the loan. For example, use 6%/4 for quarterly payments at 6% APR.

Formula result = -169.105644

Help on this function
Conditional Formatting

• Specifying the format of a cell under certain conditions is called **conditional formatting**

• Choose the cells, and choose to format them, and choose conditional formatting

• You will get a dialog which varies by spreadsheet type
Conditional Formatting
Conditional Formatting
Importing Data

• Much of the data we are interested in comes from some other source
• It has probably already been organized
• This other data is called *foreign data*
• Importing previously formatted data into a spreadsheet can be tricky
• Spreadsheet software makes it easier if guidelines are followed
Tab-Delimited Data

• Spreadsheets prefer to import foreign data as *tab-delimited text*
• “Text” means ASCII text or files with a .txt extensions
• Numbers are represented as individual numeral characters rather than a single binary number
Tab-Delimited Data

• “Tab-delimited” means that each cell’s entry is delimited or ends with a tab in the file
• Each row is delimited with a return
• There are other possible delimiters:
  – Spaces
  – Commas
• Copying and pasting tab-delimited text is a simple way to import foreign data
Tab-Delimited Data

• Lists with some other form can often be converted into tab-delimited form
  – Copy the foreign data into a text editor or word processor
  – Editing it using *Search/Replace*, using the placeholder technique

• The goal is to substitute a tab or other delimiter for a delimiter in the file
Tab-Delimited Data

- World Wide Web information is already in text form
- Some spreadsheet software allows for copying a table from HTML and pasting it into a spreadsheet
- If it doesn’t work, try another browser before beginning the task of reformatting the foreign data
Guidelines for importing foreign data

• When possible, save foreign data as tab-delimited *ASCII* text in a file with a `.txt` extension.

• When foreign data comes from the Web, select a browser that supports *Copy/Paste* of tagged tables.

• When the foreign data format is messed up, use a text editor with *Search/Replace*, apply the placeholder technique, and write the revised data with a `.txt` extension. Import the resulting file.
Arranging Columns

• Spreadsheets are designed to manipulate rows and columns of information easily

• To re-arrange columns:
  – Insert a new empty column where you want a column moved to
  – **Cut** and **Paste** the column that is to be moved into the empty column
Summary

• In this chapter we explored the basic ideas of spreadsheets. We learned the following:
  – Spreadsheets present an array of cells, each of which is capable of storing one data item: a number, a letter sequence, or a formula
  – Numbers and text can be formatted so that they display as we prefer—proper font, correct number of digits, and so on
Summary

• In this chapter we explored the basic ideas of spreadsheets. We learned the following:
  – The power of spreadsheets comes from entering formulas that calculate new values based on the values in other cells
  – The formula is one side of an equation, which the computer solves for us, preserving the equality whenever the numbers that the formula depends on are changed and displaying the new value in the cell
Summary

• In this chapter we explored the basic ideas of spreadsheets. We learned the following:
  – In addition to performing arithmetic on the cells, we can apply functions to individual items or to whole cell ranges
  – Both relative and absolute references to cells are needed depending on the circumstances
  – In addition to sorting, there are functions for finding totals, averages, the maximum or minimum, and others
Summary

• In this chapter we explored the basic ideas of spreadsheets. We learned the following:
  – Spreadsheets are a practical tool for routine computing
  – It’s easy to teach ourselves more about spreadsheets simply by trying them with courage
  – Spreadsheets may be the most useful software for personal computing